Lucene search

K
amazonAmazonALAS2-2019-1153
HistoryJan 23, 2019 - 11:29 p.m.

Low: openssl

2019-01-2323:29:00
alas.aws.amazon.com
35

CVSS2

4.3

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS3

5.9

Attack Vector

NETWORK

Attack Complexity

HIGH

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

AI Score

6.4

Confidence

High

EPSS

0.003

Percentile

71.6%

Issue Overview:

The OpenSSL DSA signature algorithm has been shown to be vulnerable to a timing side channel attack. An attacker could use variations in the signing algorithm to recover the private key. (CVE-2018-0734)

Affected Packages:

openssl

Note:

This advisory is applicable to Amazon Linux 2 (AL2) Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories.

Issue Correction:
Run yum update openssl to update your system.

New Packages:

aarch64:  
    openssl-1.0.2k-16.amzn2.0.2.aarch64  
    openssl-libs-1.0.2k-16.amzn2.0.2.aarch64  
    openssl-devel-1.0.2k-16.amzn2.0.2.aarch64  
    openssl-static-1.0.2k-16.amzn2.0.2.aarch64  
    openssl-perl-1.0.2k-16.amzn2.0.2.aarch64  
    openssl-debuginfo-1.0.2k-16.amzn2.0.2.aarch64  
  
i686:  
    openssl-1.0.2k-16.amzn2.0.2.i686  
    openssl-libs-1.0.2k-16.amzn2.0.2.i686  
    openssl-devel-1.0.2k-16.amzn2.0.2.i686  
    openssl-static-1.0.2k-16.amzn2.0.2.i686  
    openssl-perl-1.0.2k-16.amzn2.0.2.i686  
    openssl-debuginfo-1.0.2k-16.amzn2.0.2.i686  
  
src:  
    openssl-1.0.2k-16.amzn2.0.2.src  
  
x86_64:  
    openssl-1.0.2k-16.amzn2.0.2.x86_64  
    openssl-libs-1.0.2k-16.amzn2.0.2.x86_64  
    openssl-devel-1.0.2k-16.amzn2.0.2.x86_64  
    openssl-static-1.0.2k-16.amzn2.0.2.x86_64  
    openssl-perl-1.0.2k-16.amzn2.0.2.x86_64  
    openssl-debuginfo-1.0.2k-16.amzn2.0.2.x86_64  

Additional References

Red Hat: CVE-2018-0734

Mitre: CVE-2018-0734

CVSS2

4.3

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS3

5.9

Attack Vector

NETWORK

Attack Complexity

HIGH

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

AI Score

6.4

Confidence

High

EPSS

0.003

Percentile

71.6%