Lucene search

K
amazonAmazonALAS-2015-589
HistorySep 02, 2015 - 12:00 p.m.

Medium: pam

2015-09-0212:00:00
alas.aws.amazon.com
22

6.5 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

LOW

Integrity Impact

NONE

Availability Impact

LOW

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

5.8 Medium

CVSS2

Access Vector

NETWORK

Access Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:N/A:P

0.009 Low

EPSS

Percentile

82.2%

Issue Overview:

It was discovered that the _unix_run_helper_binary() function of PAM’s unix_pam module could write to a blocking pipe, possibly causing the function to become unresponsive. An attacker able to supply large passwords to the unix_pam module could use this flaw to enumerate valid user accounts, or cause a denial of service on the system. (CVE-2015-3238)

Affected Packages:

pam

Issue Correction:
Run yum update pam to update your system.

New Packages:

i686:  
    pam-devel-1.1.8-12.32.amzn1.i686  
    pam-1.1.8-12.32.amzn1.i686  
    pam-debuginfo-1.1.8-12.32.amzn1.i686  
  
src:  
    pam-1.1.8-12.32.amzn1.src  
  
x86_64:  
    pam-devel-1.1.8-12.32.amzn1.x86_64  
    pam-1.1.8-12.32.amzn1.x86_64  
    pam-debuginfo-1.1.8-12.32.amzn1.x86_64  

Additional References

Red Hat: CVE-2015-3238

Mitre: CVE-2015-3238

6.5 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

LOW

Integrity Impact

NONE

Availability Impact

LOW

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

5.8 Medium

CVSS2

Access Vector

NETWORK

Access Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:N/A:P

0.009 Low

EPSS

Percentile

82.2%