Lucene search

K
alpinelinuxAlpine Linux Development TeamALPINE:CVE-2022-44638
HistoryNov 03, 2022 - 6:15 a.m.

CVE-2022-44638

2022-11-0306:15:10
Alpine Linux Development Team
security.alpinelinux.org
22
libpixman
heap-based buffer overflow
rasterize_edges_8
integer overflow
pixman_sample_floor_y
unix

CVSS3

8.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

AI Score

9.3

Confidence

High

EPSS

0.003

Percentile

71.9%

In libpixman in Pixman before 0.42.2, there is an out-of-bounds write (aka heap-based buffer overflow) in rasterize_edges_8 due to an integer overflow in pixman_sample_floor_y.

OSVersionArchitecturePackageVersionFilename
Alpine3.13-mainnoarchpixman< 0.40.0-r3UNKNOWN
Alpine3.14-mainnoarchpixman< 0.40.0-r3UNKNOWN
Alpine3.15-mainnoarchpixman< 0.40.0-r4UNKNOWN
Alpine3.16-mainnoarchpixman< 0.40.0-r4UNKNOWN

CVSS3

8.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

AI Score

9.3

Confidence

High

EPSS

0.003

Percentile

71.9%