logo
DATABASE RESOURCES PRICING ABOUT US

Moderate: gcc security update

Description

The gcc packages provide compilers for C, C++, Java, Fortran, Objective C, and Ada 95 GNU, as well as related support libraries. Security Fix(es): * Developer environment: Unicode's bidirectional (BiDi) override characters can cause trojan source attacks (CVE-2021-42574) The following changes were introduced in gcc in order to facilitate detection of BiDi Unicode characters: This update implements a new warning option -Wbidirectional to warn about possibly dangerous bidirectional characters. There are three levels of warning supported by gcc: "-Wbidirectional=unpaired", which warns about improperly terminated BiDi contexts. (This is the default.) "-Wbidirectional=none", which turns the warning off. "-Wbidirectional=any", which warns about any use of bidirectional characters. For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.


Affected Package


OS OS Version Package Name Package Version
almalinux 8 cpp 8.5.0-4.el8_5.alma
almalinux 8 gcc 8.5.0-4.el8_5.alma
almalinux 8 gcc-c++ 8.5.0-4.el8_5.alma
almalinux 8 gcc-gdb-plugin 8.5.0-4.el8_5.alma
almalinux 8 gcc-gdb-plugin 8.5.0-4.el8_5.alma
almalinux 8 gcc-gfortran 8.5.0-4.el8_5.alma
almalinux 8 gcc-offload-nvptx 8.5.0-4.el8_5.alma
almalinux 8 libitm-devel 8.5.0-4.el8_5.alma
almalinux 8 libitm-devel 8.5.0-4.el8_5.alma
almalinux 8 libquadmath-devel 8.5.0-4.el8_5.alma
almalinux 8 libquadmath-devel 8.5.0-4.el8_5.alma
almalinux 8 libstdc++-devel 8.5.0-4.el8_5.alma
almalinux 8 libstdc++-devel 8.5.0-4.el8_5.alma
almalinux 8 libstdc++-docs 8.5.0-4.el8_5.alma
almalinux 8 gcc-plugin-devel 8.5.0-4.el8_5.alma
almalinux 8 gcc-plugin-devel 8.5.0-4.el8_5.alma
almalinux 8 libstdc++-static 8.5.0-4.el8_5.alma
almalinux 8 libstdc++-static 8.5.0-4.el8_5.alma

Related